Application outage
Incident Report for Strigo
Postmortem

Our application crashed due to a surge of API requests. A problem with our rate-limiting mechanism was not protecting us from that scenario.

We're already taking measures to prevent that, and are introducing more robust rate-limiting on our API endpoints, alongside our new API, which will be deployed in the following days.

We’re sorry for the inconvenience.

Posted 13 days ago. Nov 29, 2018 - 10:36 IST

Resolved
Our main app (management + live) crashed due to a high load on our API endpoint.
Posted 14 days ago. Nov 28, 2018 - 18:44 IST