No RDP to remote desktop labs

Incident Report for Strigo

Resolved

We found a resource access problem in our eu-west based RDP relay servers and restarted them.
Posted Apr 01, 2026 - 20:08 IDT

Update

We are continuing to investigate this issue.
Posted Apr 01, 2026 - 20:05 IDT

Investigating

Labs based on remote desktops and RDP connections are not accessible right now.
Posted Apr 01, 2026 - 19:47 IDT
This incident affected: Strigo service and Lab regions (AWS EC2 (eu-west-1)).