Slow response times in the classroom for large events
Incident Report for Strigo
Resolved
We've identified several causes for slowness (mainly related to how we dealt with realtime data flows between our client and our server) and resolved them.
Posted Apr 23, 2020 - 21:55 IDT
Investigating
We're currently experiencing a performance-related issue when running large events (~60+ attendees). There is a strong correlation between the number of workspaces in the event and the degradation in performance.

This means that both instructors and students in the classroom will experience long transition times when switching between tabs or navigating presentation slides, and with other interactions with the user interface.

Lab and video performance seem to be working regularly.

We're looking into the problem and will update as we gather more insights.

We apologize for the inconvenience.
Posted Apr 16, 2020 - 21:04 IDT
This incident affected: Strigo service.